KB 68 - PowerConnect JAVA UI Error, Input Disabled After Patching
KB 68 (Java): PowerConnect JAVA UI Error, Input Disabled After Patching
Category: Problem | Priority: High |
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Platform: Java(NW) | Version: 1 from 23.03.2021 |
Description
After upgrading the PowerConnect, the UI seems to be disabled as no input is allowed and there is a Java error, “java.lang.IllegalArgumentException: local part cannot be “null” when creating a QName”

Cause
NW is caching the UI component so when upgrading from .24 to .26 the UI is still expecting 18 operations from the WSDL but we’ve added a further 4 in the new version so there’s a mismatch. Forcing the service group to be re-processed fixes this because it seems to invalidate whatever cache is storing the UI config.
Resolution
Go to NWA -> SOA -> Application Scenario and Communication -> Application Communication

Click on the PowerConnectSG service group.

Then click Edit and choose provider system None, click Save, then choose provider system Local and click Save again this will force the service group to get refreshed and should fix the UI without needing a restart.


The PowerConnect Java agent will work again. Access the application using the following URL: http://<serverhost>:<port>/webdynpro/resources/com.powerconnect5/spcj_wd/SapPowerConnectJava#
Product version
Product | From | To |
PowerConnect [NW,S4HANA,S4HANA Cloud] | [Affected version from] | [Affected version to] |
[SAP product version]
Product | Component | From | To |